2007 BMW 750 Li

I purchased a new AUC sensor to install in my ’07 750 Li. By all accounts, it is mounted to the upper fan shroud on the passenger’s side. I have spent the last 2 hours searching for it, and have removed all the components that I should need to in order to find it. It appears that it is suppose to be mounted in the area marked, but there is no sensor, no wire…nothing but the fan motor wiring (the dangling connector is for the mass air flow sensor). Does anyone have any ideas where this is located on the vehicle?? I have looked around the cabin filters/firewall as well and nothing.

7 thoughts on “2007 BMW 750 Li”

  1. Thanks for the response. My model is the “post face lift” model, so set up is different (i.e., no expansion tank on shroud). I have taken off both filter boxes, looked around and still don’t see the AUC sensor. Definitely does not appear to be on the shroud. Any other thoughts? Thanks.

  2. We need a three wire plug(GRN/GRY)(GRY/BLK)(BRN), if you see this floating around not plugged into anything…. yeah, not that easy. Lets dig a little deeper.
    I would have to guess at this point it was removed or fell, look for the plug or wiring harness.

    All the manuals and books indicate:

    Sensor for automatic air-recirculation control (IHKA High only)
    The AUC sensor is installed at the top of the fan cowl. The sensor is exposed to the sideways downwind from
    the auxiliary fan.

    2007 BMW E66 AUC Sensor location

  3. Thanks for the response. I spent another hour or so this morning looking. I removed a few more parts and looked all the way down to the splash shield under the engine and nothing. No plug not connected or wires. I followed the harnesses around the front end as well. This is really getting frustrating.

  4. Did you find the sensor? I have the same problem… i seached for hours and cant find the sensor ore the connector.

Comments are closed.