Aug 022010
 

I have a 2000 Chrysler Town and Country with 3.3L V6. Have not had any real problems in the past. A few days ago, was driving on the highway. The vehicle began to lose power, the speedo guage surged randomly, the oil light came on, and the vehicle stalled. I have not been able to get it started since. Thought maybe the alternator went bad and drained the battery. Put new battery in to no avail. When the ignition switch is turned on, there is no click from the starter solenoid (also new), only the oil idiot light stays on (the oil level is fine). When trying to start, you can hear the relays engaging. Tried to swap the one for the starter, thats not it either. Engine code reader shows only an error trying to read them. Any ideas what to check next?.

May 082010
 

I have a 1995 Chrysler LHS and my interior lights has problems. This is what it is doing first when I get out of car and shut door the lights will not turn off now if I get back in car and start my engine then shut door they will shut off then I have to turn engine off then remove key then get back out of car and shut door then they will shut off. Now I have already checked the switches on each door and they are good plus my message center shows all door are shut when they are shut and when I open one it shows they are open so I do not believe it has anything to do with door switches. Do you have any suggestions as to what my problem may be?

May 032010
 

2006 Chrysler Sebring  2.4 L  4 cyl

When cold, engine starts and then dies for 3 or 4 times before finally starting and then runs fine.  Only happens when we first try to start it each day or after it sits and coold for the day.  Engine code P1607 was read but may not be relevant.  Any ideas?

Jan 312010
 

car will start and run until it warms up then it boggs and dies when you acclerate.It died going 65 mph as well. The check engine light only came on when I removed the oxygen sensor then put it back in. So I had the car tested at parts store. They said it was the throttle position sensor. On the way home the light went out. The next day I replaced the sensor and it didnt work. What do I do next?