Apr 162014
 

2002 Dodge Durango R/T 5.9 L

Won’t engage on turn-over (Unless I put foot on gas pedal, & then have to hold it in or dies…..sometimes if I rev really hard a few times will then stay Idle but only in Park. If I try & drive it around block to charge battery up it’ll just quit) This just started to happen
Before I was noticing that my transmission is not engaging at proper RPM…. I can manually get 1st-2nd at 2.5 RPM but 2nd-3rd will do it auto…… I can’t do a fast speed climb either….transmission won’t grab with accelerator down …..? Thanks a lot.

Apr 162014
 

After running 10 -15 minutes oil leaks heavy near rear main seal. Replaced the rear main seal twice (the first seal did not look bad but we did not want to chance it) and replaced the engine oil pan gasket with second seal. What else would cause oil leak in that area?

Mar 202014
 

Looking for answers to a problem with my 2005 Dakota 3.7 V6. It misses on slow acceleration between 35 and 55 mph. . if I mash the pedal it accelerates fine. . 2 check engine codes come up.  PO152 and PO300. . I have changed cat converter (whole unit) and all 4 O2 sensors.. upstream and down stream. . Fuel pressure is 52 PSI at idle and 62 PSI when revved up.. I have a good scanner but a lo of the info it gives me I have yet to understand.

Jan 192014
 

Starts and runs good, can get in it an go to town 15 miles one way and 90% of the time when I get back in it to leave it won’t start. Cranks over good but NOT getting FIRE. Have let it set over night, and sometimes 3 or 4 hours it will start right back up.