May 242011
 

Heater Blower Motor High Speed and AC compressor not working. Would this be the fuse located beside the battery (HVAC). Normally I would just replace the fuse but I have noticed a strange behaviour when turning the blower control to high. The interior lights get really bright for a second and if I do it two or three times the ABS light and the Engine light will come on. I have tried to find a wiring diagram for the circuit but was unable to obtain one. I am worried that there is a major electrical fault here.

May 132011
 

I have no dash lights and the ABS and TRAC OFF lights are both on. This car has a feature that when it is dark enough the head lights automatically come on. Since the dash lights went out, I have to manually turn the head lights on. We have checked all the fuses. Any suggestions?

Feb 032011
 

recently my mother had a tune up done to her 98 oldsmobile, new plugs, new wires,oil change,and new O2 sensor and even had new tires put on. But now after that her gas millage has dropped from about 28mpg to about 18mpg. Is there anything that could be causing the poor gas millage. She is still using the same type of gas and isn’t driving more agressively. Kind of at a loss to why it would be getting such poor millage after everything that was done to improve the running condition. And she had the gas lines and tank checked for leaks and there were none. I have been trying to think of another reason but im at a complete loss as to what it might be.

thanks

Sep 132010
 

how do i know if my pcs went out? i was driving down the road all of the sudden it was like i was in neutral no forward or reverse.changed fluid and filter,still nothing. there was no noise or any thing when it happened just kind of like it went into neutral no slip or anything

Jul 102010
 

The harmonic balancer in my Oldsmobile went bad. I bought a new Balancer and removed the old balancer. The bad balancer was extremely tough to remove. I rented a Pully Puller from my local Autozone. The Pully Puller wasnt big enough to remove the balancer completely. Therefore,  I used a socket as a spacer. I put the socket in the crank shaft (where the bolt goes that holds the balancer in place). I got the bad balancer off but got the socket stuck in the shaft. I tried drilling the socket to  smaller width and then hitting it with a pick and hammer. Those stainless steel sockets are tougher than i thought. Then I took it to my mechanic who tried heating it then removng it, no success. There is brass behind it so it cant get too hot. He told me to talk to a machinist and see what they could do. This car isnt worth much and im not looking to spend much to fix it. Does anyone have any advice and/or help with my problem?