Apr 302014
 

My cars started out dieing out once it was put into drive. I’ve done some research and got several answers. We think it might be the torque converter. There is no code to pull. It idles fine in p,n and drives fine in reverse. We checked for vacuum leaks and didn’t find any. Once the car warms up it will drive but very rough. Is there something we haven’t checked yet or is there any thing else that might be the problem. The transmission was rebuilt about 3 years ago. Thanks for your time.

Feb 072014
 

I have a 96 gmc Sonoma that I bought with about 83000 on it and now it only has around 86000.  Since I bought it when driving it in OD it has never wanted to stay in overdrive when it gets hot.  It will do just fine when its cold and it will do just fine when you drive it in D but as soon as it gets hot the rpms will go up and down but it is absolutely not slipping im very sure of this.  I have replaced the fluid and filter but that’s about it.  I have transmission experience so if there is any more information I can give you to help me out with this just let me know.  Thank you very much for your help.  The transmission is very very clean like it has been out and possiblely rebuilt but im not for sure about that. Also wanted to add there are no check engine lights or anything on.

Jan 272014
 

I just had my transmission repaired and picked up vehicle yesterday afternoon. This morning there is HUGE puddle of tranny fluid underneath it. What could this mean?? I paid over $2000 and I am very upset over this. Don’t know if I should take it back to the same repair company to have fixed……(don’t have much confidence at this point) or would it be better to dispute the charge with my credit card company and take it somewhere else?

Jan 202014
 

yesterday the car arrived.. tranny was running fine, i thought.. than a mech. drained tranny fluid.. he said he installed the correct level.. he did it while laying on the ground.. backyard mech..i had 2 gallons for the filling.. i think he used less than a quart, if that.. when i went to put it into gear it would not move.. went thru all the gears.. it’s an automatic tranny… nothing!!! when he drained the fluid less than several quarts came out… he said it needs seals that can be installed by opening the bottom pan.. and it’s an $800 job if done in a shop.. i was at –advance auto parts and they said they have the flow seals…the tranny seemed to run good until the mech drained the fluid…… i believe the tranny should have 8+ quarts installed to have it run right….. moveover, at the store he pulled fluid that was—not–dextron 111……… the –only–type that should be used…. within 12 hours i will fire him from doing anymore work on my trooper.. thanks for a competent response, okay?????

Dec 262013
 

2000 Mazda protege lx.  I think my ex neutral slammed it. i was not in the car but he broke the cv shaft and a pin in the transmission. cv was replaced and metal shavings were cleaned out of transmission fluid tray. ran good for few day then last night started having trouble getting up to speed and o/d light was flashing. i parked it asap. any idea whats up?

Nov 252013
 

HI I’M AMIN FROM IRAN . I HAVE A 1999 GRAND CHEROKEE LAREDO . 4.0 L, 6 CYLINDER. I HAVE PROBLEM WITH GEAR SHIFTING . I CHECKED IT WITH DIAGNOSTIC TOOL . AND CHANGED THE SHIFT SOLENOID . BUT STILL NO SHIFTING . THEN I CHANGED ECU . CHECK ENGINE LIGHT GO OFF AND HAVE NO DTC BUT STILL NO GEAR SHIFTING . HELP ME PLEASE

Nov 092013
 

My transmission is slipping so I was changing the transmission shift solenoid (That didn’t do any good)but while changing the solenoid on the drivers side, a little rod popped out, what is that little rod and is that the reason my transmission is slipping or do I need a new or rebuild transmission?