Jul 302015
 

Hi, when my truck has been running for awhile and you slow down completely at like a stop sign it boggles down and shuts off. The rpms lower then just stops. I am not sure what it could be. Could be multiple just wondering your best guess? Also after a couple minutes it fires right back up no problem and runs great.

Jul 272015
 

While driving my battery light, oil light, and my lighting bolt light on.also in the dash PRND all had square around all of them.I got home car wouldn’t say anything everything works. After a while it started up.But now it does it from time to time.what is my problem

Jul 102015
 


okay so when i gt my car 2 1/2 yrs ago it ran but there was timing chain problems as well as strut and suspensin problems that were all fixed… there was also an electric probem when i would accelerate the car would die about 5 minutes after a full charge so i replaced the battery with a really good one and cleaned the corrosion off and also tested the wires or so i was told… well i just came back from indy to plate my car and drive it home and the battery is dead… there were no lights left on, no car door open and my key fob though its dead is in the house about 100 ft or so away……. I am tired of replacing my vehicle piece by piece so if anyone could give me correct information and not “well it could be this this this and 72 items and 10k later….. also i have a python car security pop out door system thing…. as well as a massive sound system that is currently disconnected as well as the radio the only thing that is not disconnected is the thing that makes all my speakers work but i dont think it has any power running to it…… but the wires run right through my center console….. and i dont have the patience to take each seat out nor do i have thin arms or a car lift……

batteries were thrown away due to dead cells and the amp and speakers have been disconnected as well as the radio

my main accessible electric.

Jul 072015
 

Driver side running lights front and rear don’t work bulbs are fine. There seems to be just a single fuse for the running lights so that is OK. The van is modified by Braun to be wheel chair accesible but that doesn’t seem to have anything to do with the lights compared to a base van. Turn signal and emergency flashers work fine.

Jun 302015
 

Have 2007 Dodge caliber base model no extras. Plane Jane. Anyhow got new battery thought old one kicked bucket after 6 months put new battery in everything worked. So now to find why old battery drained turned everything off took keys out and on the instrument cluster where it shows the manual transmission position P N D R L well this indication these lights all stayed on even after several minutes didn’t shut off with keys out? What’s going on? Any fix ideas? Hope it’s just a relay stuck or something.
Thanks. Scott.

Jun 262015
 

truck is rarely used, and now the brake pedal sticks and eingages brakes . I have to lift pedal back up to release brakes. I found one fluid chamber empty,assuming a leak and replaced with new master cyclinder, bleed and still the same problem. Is there a spring or something worn on the pedal? The brakes are power with disc in the front. Once I pull the pedal up manually brakes release.

Jun 252015
 

I have 98 dodge grand caravan. It started to overheat when driving… Period. We replaced the thermostat… Did oil change and replaced coolant in radiator…. Then replaced the cooling fan relay. The check engine light was still on, but no codes show when the auto parts guy hooked up the tester, and the ac still wasn’t blowing cold air. If you check the fans with 12v they work. So we ordered an ECM online and followed the directions to change the computer. The van stopped overheating and the ac blows cold. However it started having a whole different set of issues…. Throttle wasn’t responding.. Jerky…sounded like it was misfiring… And then got to the point where it was shutting down at an idle, and did not want to drive period…. in 2 days time of changing the computer. My husband put the old ECM back on and the new problems ceased and we are back to the overheating. The fans did not run with either computer unless we wired them directly to a 12v.

We are a single vehicle family with 2 toddlers and the heat indexes have been 100° + and I am terrified of taking them anywhere. Any help would be greatly appreciated!!!!