Jul 182015
 

I recently change the transmission it is a manual 4 speed over drive everything was fine for about a week or two.Now the the speedometer,odometer and the trip button is not working at all

Jul 162015
 

I replaced a fuel pump on my truck….now I have no power to the fuel pump, I checked the fuel pump relay, it is good, however the fuel pump fuse next to it is getting no power to it. could I have a bad pcm possibly?

Jul 132015
 

today my ABS and brake light came on and stayed on. also, the air is still cold but barely blows out. it blows out stronger when driving but not at all when stopped. otherwise, the engine and all other electrical systems are all working just fine. what could be the problem

Jul 102015
 

My 700r4 tranny went into limp mode due to a burnt 3-4 clutch. I bought a 2wd 700r4 (same year) for cheap with low miles. I want to know what I need to do to be able to drop my current 4×4 tranny and install the new 2wd 700r4 to convert it to 4wd. I have all parts for the 4wd.

Jul 072015
 

Trailer Wiring Question. I have a 1977 Shasta trailer. All lights on the Suburban work fine, but the running lights on the trailer don’t work. They did at one time, but not now. The brake lights, turn signals and hazards work fine, but not the running lights. I tested the 6 pin connector on the Suburban and the I’m getting power to the running light post. (Of the 6 posts this is the top middle that shows power.) What’s strange is I only have four wires coming out of the trailer connector. (See Picture)

When I test these wires with my circuit tester I get power as follows: Blue Wire – Left Turn Signal. Brown Wire – Right Turn Signal, Brown Wire – Hazards, Brown Wire – Brake Lights. I get no power from any wire when I turn on my head lights. (I assume the black wire is my ground as it is connected to the trailer.) The 6 pin female connector on the trailer may be bad, but I wouldn’t know what to replace it with that has only 4 wires… I’m leaving for vacation in a few days and don’t have the time or expertise to rewire the whole thing. As you can tell, I’m pretty clueless on mechanical/electrical stuff so any help you can offer will be appreciated. Also, I bought both the Suburban and the trailer used and didn’t have anything to do with the wiring on either.