Jul 062015
 

How do I remove the old gear shift knob from my STS? The old one has fell apart into pieces.I have a replacement knob,but I have been unable to remove the pieces of the old one.I have been unable to find a screw or a clip that holds it on.

Jun 162015
 

my blower motor when out I bought a new one blew that one out and now I have another one I plug it in it goes to low to hi back to low and off but why it’s on it pulsates with power up really fast down every few seconds and then when its been running for a little while it goes really high when I turn off the motor it stays on and stops pulsating with power I have to pull the fuse to get it to stop this is driving me crazy please help

Jun 072015
 

My headlights go on during the daytime but automatically shut off when it gets dark or even if I enter a tunnel. Then my dashboard lights come on but headlights stay off. Is there a sensor that may need to be replaced? And where is its location? Under the hood or in the dash somewhere? Have checked the fuses and they are intact. Please advise

May 262015
 

My car will not start. When you turn the key forward, everything lights up like normal. But when you go to crank it, everything dies out. no lights, no dashboard, no anything. Any ideas?

May 012015
 

Car has 56000 miles on it and it using about a quart of oil every 500 mile . Where it going and how do I go about getting it fix.

Apr 272015
 

Hi All: I have a 2007 Cadillac CTS I bought used last March. In May 2014 I had to replace the battery. In Oct 2014 I had to replace the alternator and the battery again. Two weeks ago I had to replace the starter. The car will not start without a jump and once you turn it off it does not start again without a jump. I had the battery tested at autozone and they said the battery is fine. The car also does weird things. The radio will turn up out of no where, the back drivers side brake light keeps blowing, the sun roof opens when it wants to. The cigarette lighter works sometimes then not other times. Please help I’m at a total loss.

Mar 132015
 

Cadillac CTS

2005 Cadillac CTS

Purchased vehicle new, from dealership. Car has always been reliable, except for a fuse-blowing problem, in which the car wouldn’t start, back in 2007. That was the 10a fuse, listed as (HTR VLV/ CLTCH), which is part of the ‘Jumper to Start Relay Coil for Automatic Transmission’. After blowing 3 or 4 additional fuses, I replaced it with a 15a circuit-breaker fuse, and have had no problems since.
The same thing is now happening again, with the car not starting. Note: Battery is fully charged, and all lights and accessories are working. I thought my current problem may have been with the same fuse, so I put in a new one, and still nothing. I then tried putting in a new Starter Relay, and that did nothing.

When I put the key in the ignition, turn to accessory, everything lights as normal, continue to start, I get nothing. Now I can’t turn the key all the way back to remove it, so it stays in the access. position. I have to push the release pin under the column to get the key out. I have now discovered that if I use a test-light, from the neg. side of the battery to one of the pins of the starter relay, I can start the car. This was done with both the old & new relay. The car will stay running.

When I shut the car off, I can now start it with the key, numerous times. If I return to start it in 15 or 20 min., it starts fine with the key. After a half hour or so, it will no longer start with the key, and I have to jump it with the test-light again. So, where I am at now, is I can jump it, go anywhere, and do anything, as long as the car is only turned off for 15min. or less, in order to start it with the key. It seems that by jump-starting, it energizes something for a short period only. But strangely enough, it started yesterday, after an hour of sitting, then 3 hours later, it didn’t. Everything that I have done so far, is from the advice of a long-time friend, and auto mechanic, who specialized in electrical problems, but does not know everything about many newer cars, as he is now retired.

I am now at a ‘stand-still’, with no other options, and need an experts advice. Thank you.

Jan 182015
 

I just resealed the oil pan and changed the water pump. I filled all of the fluids. When I restarted the car the valves are rapping really loud. It sounds like a diesel. I am thinking the oil is not circulating through the engine. I do not recall disconnecting anything electrical that would limit the pump from circulating the oil. Any ideas of what it could be? Appreciate your help.